admin管理员组

文章数量:821308

强制ie开启兼容模式的标签

强制ie开启兼容模式,可以在head中放一段meta标签,指定ie使用某一版本模式进行浏览。比如:

指定浏览器使用ie7/ie5模式

<meta http-equiv="X-UA-Compatible" content="IE=7" > //强制以IE7模式渲染页面
<meta http-equiv="X-UA-Compatible" content="IE=5" > //强制以IE5模式渲染页面
<meta http-equiv="X-UA-Compatible" content="IE=Edge" > //始终以当前浏览器最新的文档模式来渲染页面

添加完meta标签,还需要把DOCTYPE的定义去掉,其实这样就可以了:

<!DOCTYPE html>  

如果使用分号分隔,则会为不同版本设置兼容级别。例如:

<meta http-equiv="X-UA-Compatible" content="IE=7;IE=9" > //将IE8和IE7按照IE7标准渲染,但是IE9还是按照IE9的标准渲染。它允许有不同的向后兼容水平。

注意:浏览器必须是ie8及以上版本才支持,ie6不会支持以ie7模式浏览的。

本文标签: 强制ie开启兼容模式的标签