admin管理员组

文章数量:815885

Alphapose配置与运行中的问题

环境配置参考的连接

运行中遇到的主要问题

1、forserver

在运行Alphapose的过程中,出现了以下错误。

                           

查阅资料之后,给出了很多解释,最后参考了一篇博文中的操作,就没保存了,具体原因我也没太弄明白,于是打算先记下该操作。下图为当时别人博文中的具体做法,只需要在处理图片的时候,最后加一个--sp就不会报错了。

                           

2、RuntimeError:CuDNN error:CUDNN_STATUS_SUCCESS

                              

原因分析:CUDNN问题是cuda版本与显卡不匹配。

首先,我用pycharm和git两种方法都尝试运行错误中显示的dataloader.py和darknet.py两个python文件,单独运行时并没有显示错误,排除了代码本身问题。

然后查阅别人的博客,都说可能pytorch版本和cuda版本不匹配,但pytorch通过命令pip3 install .4.1-cp36-cp36m-win_amd64.whl下载,再检查中cuda版本为9.0,torch版本为0.4.1,与命令一致。

接着,我又在pycharm中运行train_sppe文件夹中demo.py时,pycharm显示要求pytorch0.4.0,

所以,最后我还是卸载pytorch0.4.1重新安装pytorch0.4.0,之后重新下载cudnn9.0,保持cudnn和cuda版本一致,最终得以解决。下面我自己笔记本和学校服务器上的配置对应版本,仅供参考。

自己的:GTX 960M显卡-----cuda9.0

学校的:学校RTX2070-----cuda9.2

3、json中关键点信息与输出的图片的关键点信息不匹配

当我将图片关键点信息输出时,json文件中的信息是17个关键点的坐标信息,而输出后的图片上的关键点是18个关键点。如下图所示。

                                   

 

对此,我至今还未找到问题出在哪里。网上好像没人出现过这样的问题,如果有人知道问题在哪,还望能告诉我,万分感谢!

本文标签: Alphapose配置与运行中的问题